
3D Model File Importing Guide 
zSpace Studio 

Version - zSpace Studio 2014 

This guide is for learning the process of importing a 3D model file into zSpace Studio. Use this guide to 

determine what file formats Studio supports. If you have a 3D model in an un-supported format, this 

guide will also walk you through the process of re-exporting your 3D model in a format that will load 

in Studio. 

 

In the “File Format Quick Guide Q&A” section, you will find basic information on what file formats are 

supported by zSpace Studio. You can easily compare your 3D model file’s format against the formats 

listed to determine whether Studio can load it or not. 

 

For further details on file formats and preparing model files for importing into Studio, use the table of 

contents to navigate within this document. This guide currently details the exporting and importing 

process for four 3D modeling programs: Autodesk 123D, Autodesk Maya, SketchUp, and Solidworks. 

Choose a program to learn what file formats it can export as, then use that program’s “Guide to 

Exporting…” walkthrough to obtain a supported file format for Studio. 

 

You can also read notes and view screenshots of models in Studio of various file types to get a sense 

of what your model will look like when imported into Studio. 
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File Format Quick Guide Q&A 
Q: What file format is the best to use in Studio? 

A: DAE (OpenCOLLADA) files work the best in Studio. They’re guaranteed to load and look the best. 

Check the table of contents to see which programs will let you save or export a model as an 

OpenCOLLADA DAE file. 

 

Q: What file formats can zSpace Studio load? 

A: These are the file formats Studio will try to load. Your level of success depends on the individual 

model and the program used to export the model. 

Studio Will Try to Load These File Formats 

".dae", ".fbx", ".stl", ".xml", ".blend", ".bvh", ".3ds", ".ase",  
".obj", ".ply", ".dxf", ".ifc", ".nff", ".smd", ".vta", ".mdl", ".md2", ".md3", 

".pk3", ".mdc", ".md5mesh", ".md5anim", ".md5camera", 
".x", ".q3o", ".q3s", ".raw", ".ac", ".irrmesh", ".irr", ".off", ".ter", 

".mdl", ".hmp", ".ms3d", ".lwo", ".lws", ".lxo", ".csm", ".cob", ".scn", 
".xgl", ".zgl" 

DAE, FBX, and STL files have been the most reliable formats from those listed in the box above. It is 

recommended that you use a 3D model file in one of those three formats for the best results. 

 

Q: I’ve got a DAE / FBX / STL file, but it won’t load in Studio. Why? 

A: Depending on what program exported the model, the file may trigger an error message as Studio 

and the underlying Unity engine can fail to understand how to open it. One way to get around this 

issue is to re-export the model using a different program or to change the file format to a different 

supported format. 

 

 

 

 

 

 

 

 

 

 



Autodesk 123D Design 

What files can 123D Design open or import? 

Will Import Will Open 

SVG 123DX 
OBJ 

SAT / SMB 
STP / STEP 

STL 

 

What files can 123D Design save as or export? 

123dx 

This is a format used by 123D Design when saving projects in progress. 

● You can get this file format option by selecting “Save...”. 

● This file format will not open in Studio. 

 

STL 

This format is commonly used for 3D printing. This is a file format supported by Studio. 

● You can get this file format option by selecting “Export STL”. 

● This file format will open in Studio. 

 

Guide to Exporting Your Autodesk 123D Design Model 
This section will guide you through exporting a 3D model file in 123D Design that results in a format 

that will load in zSpace Studio. This guide will focus on converting a model into a STL file, since that is 

the only available file format option from this program that will load in zSpace Studio. 

1. Open or load your model in the scene. You can drag 

your model file into the scene to load it. 

 

2. Make any last-minute changes to your model, if 

necessary. You won’t be able to edit your model in 

Studio. 

 

3. Click on the downward-pointing arrow in the top 

control bar (see green arrow in screenshot to the 

right) to bring up the file menu. 

 

4. Select “Export STL” (see orange box) to export your 

model as an STL file. This is a file format recognised 

by zSpace Studio.  



5. In the export window, name your model file. 

 

6. Make sure the “Save as type” field has “STL Files” 

selected. 

 

7. Select a location on your computer to export your 

model file to. 

 

8. Click “Save” in the lower right of the export window. 

 
 
 

 

9. Open zSpace Studio. 

 

10. Click on “Import Model” on the top control bar to 

browse your computer for your STL file. 

 

11. Select the STL file and wait for it to load in Studio. 

 

 

 

Viewing Your Autodesk 123D Design Model in zSpace Studio 
Here are things to expect when viewing an STL file from Autodesk 123D Design. 

● STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL 

file will look like before it is 3D printed. 

● STL files do not show materials or textures. They will appear as a single solid color (usually 

white or grey). 

● STL files show external geometry. This means you see which parts of the model are raised or 

sunken into the model. 

● You can use the cutting plane tool in Studio to view whether your model is hollow or solid. 

 



Autodesk Maya 

What files can Autodesk Maya open or import? 

Will Import / Open 

DAE 
FBX 
IGS 
IPT 

MA / MB 
STL 

STP / STEP 

There are many plug-ins for Autodesk Maya that can allow you to import/open more file types. If you 

want to load a file with a format not listed in this box, it may be worthwhile to try searching online for 

a plug-in that suits your needs. 

 

What files can Autodesk Maya save as or export? 

DAE FBX 

Exporting with this option results in a DAE file. This is a file format supported by Studio. 

● You can get this file format option by selecting “Export Selection...” and choosing “Files of 

Type > DAE_FBX export”. 

● This file format will open in Studio. 

● You will need a plug-in for this export option. The plug-in is called fbxmaya.mll and should be 

included with Maya. Make sure it is turned on by using the Plug-in Manager. 

 

FBX 

This is a file format supported by Studio. 

● You can get this file format option by selecting “Export Selection...” and choosing “Files of 

Type > FBX export”. 

● This file format will open in Studio. 

● You will need a plug-in for this export option. The plug-in is called fbxmaya.mll and should be 

included with Maya. Make sure it is turned on by using the Plug-in Manager. 

 

OpenCOLLADA (DAE) 

Exporting with this option results in a DAE file. This is the best file format to use in Studio. Studio was 

built to run its best with this file type. 

● You can get this file format option by selecting “Export Selection...” and choosing “Files of 

Type > OpenCOLLADA exporter”. 

● This file format will open in Studio. 

● You will need a plug-in for this export option. The plug-in is called COLLADAMaya.mll. You can 

download it from here: 



https://github.com/KhronosGroup/OpenCOLLADA/wiki/OpenCOLLADA-Tools 

or here: http://uploaded.net/file/7dj43y18  

 

STL 

This format is commonly used for 3D printing. This is a file format supported by Studio. 

● You can get this file format option by selecting “Export Selection...” and choosing “Files of 

Type > STL_DCE”. 

● This file format will open in Studio. 

 

Other Export Formats 

There are plenty of other formats for “Export Selection” options, but the 4 options listed above are 

the only format options for exporting that are supported by Studio. 

 

Guide to Exporting Your Autodesk Maya Model 
This section will guide you through exporting a 3D model file in Autodesk Maya that results in a 

format that will load in zSpace Studio. This guide will focus on converting a model into an 

OpenCOLLADA (DAE) file, since that is the best file format to use in Studio. 

1. Open or load your model in the scene. 
You can drag your model file into the 
scene to load it. 

 
2. Make any last-minute changes to your 

model, if necessary. You can define 
dissectible segments in Maya using 
“Mesh” > “Combine” or “Separate” 
and these changes will be reflected in 
Studio. You won’t be able to edit your 
model in Studio. 

 
 

 

https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2FKhronosGroup%2FOpenCOLLADA%2Fwiki%2FOpenCOLLADA-Tools&sa=D&sntz=1&usg=AFQjCNHJJDdRIAvffi3W_rRRw2AN9KVZMg
http://www.google.com/url?q=http%3A%2F%2Fuploaded.net%2Ffile%2F7dj43y18&sa=D&sntz=1&usg=AFQjCNHKdi5nm8eZOuHexF7LFu4wPCVLDw


Before exporting, there are 2 steps that need to 
be taken.  
 

3. The first is to click on “Freeze 
Transformations”. If your model has 
multiple pieces, this will keep the pieces 
together in Studio (otherwise they will 
scatter across the scene when loaded 
into Studio). 

 

4. The second pre-export step is to select: 
Edit > Delete All by Type > History 
Selecting this gets rid of any extra 
information that could impact what your 
model will look like in Studio. 

 



5. Highlight your entire model. It will 
appear green or white. Then, under 
“File”, select “Export Selection…” 

 

6. In the export window, name your model 
file. 

 
7. Make sure the “Files of Type” field has 

“OpenCOLLADA exporter” selected. 
 

8. Select a location on your computer to 
export your model file to. 

 
9. Click “Export Selection” in the lower 

right of the export window. 

 
 

 
 

Note: If you do not see OpenCOLLADA as an 
option for exporting, you’ll need to download a 
plug-in. See “OpenCOLLADA (DAE)” above for 
links to the plug-in. 

10. Open zSpace Studio. 
 

11. Click on “Import Model” on the top 
control bar to browse your computer for 
your OpenCOLLADA (DAE) file. 

 
12. Select the OpenCOLLADA file and wait 

for it to load in Studio. 

 

 

 

 

 



Viewing Your Autodesk Maya Model in zSpace Studio 
Here are things to expect when viewing an OpenCOLLADA (DAE) file from Autodesk Maya. 

● OpenCOLLADA files show materials, textures, and colors. They will appear how they looked in 

Maya. In the example screenshots, I chose to make certain segments of the flashlight white, 

and others grey. 

● OpenCOLLADA files show external and internal geometry. 

● You can use the cutting plane tool in Studio to view the inside geometry of your model. 

● Any pieces you defined as individual segments in Maya will be reflected in Studio. You will be 

able to dissect your model accordingly. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



SketchUp 

What file formats can SketchUp open or import? 

Will Import Will Open 

SKP 
3DS 
DAE 

DEM / DDF 
KML / KMZ 

STL 

SKP 

 

What file formats can SketchUp save as or export? 

COLLADA DAE 

This is the best file format for Studio. 

● You can get this file format option by selecting “Export > 3D Model...”. 

● This file format will open in Studio. 

 

KML / KMZ 

This is a file format used by Google (SketchUp, Earth, 3D Warehouse). 

● You can get this file format option by selecting “Download” while browsing the 3D Warehouse 

online ( https://3dwarehouse.sketchup.com ). 

● You can get this file format option by selecting “Export > 3D Model...”. 

● This file format will not open in Studio. 

 

SKP 

This is a file format used by SketchUp. You get this file format when you save your work-in-progress in 

SketchUp. 

● You can get this file format option by selecting “Download” while browsing the 3D Warehouse 

online ( https://3dwarehouse.sketchup.com ). 

● You can get this file format option by selecting “Save as...”. 

● This file format will not open in Studio. 

 

STL 

This format is commonly used for 3D printing. This is a file format supported by Studio. 

● You can get this file format option by selecting “Export STL...”. Make sure the file format field 

says ACSII, not Binary, in the export pop-up window. 

● This file format will open in Studio. 

 

https://www.google.com/url?q=https%3A%2F%2F3dwarehouse.sketchup.com&sa=D&sntz=1&usg=AFQjCNGw6SMeG9_6tGWX1QoN_ss7DJMyWQ
https://www.google.com/url?q=https%3A%2F%2F3dwarehouse.sketchup.com&sa=D&sntz=1&usg=AFQjCNGw6SMeG9_6tGWX1QoN_ss7DJMyWQ


Guide to Exporting Your SketchUp Model 
This section will guide you through exporting a 3D model file in SketchUp 2014 that results in a format 

that will load in zSpace Studio. This guide will focus on converting a model into a DAE file, since that is 

the best file format to use in Studio. 

1. Open or load your model in the scene. 
You can drag your model file into the 
scene to load it, or open a model 
directly from SketchUp’s 3D Warehouse. 

 
2. Make any last-minute changes to your 

model, if necessary. You won’t be able 
to edit your model in Studio. 

 

 

3. Under “File”, select  “Export > 3D 
Model…”. 

 

4. Click on “Options” in the lower right of 
the export window. 

 
5. Make sure these 4 boxes are checked in 

the “DAE Export Options” pop-up 
window: “Triangulate All Faces”, “Export 
Only Selection Set”, “Export Texture 
Maps”, and “Preserve Credits”.  These 
options ensure that all the necessary 
information and materials for Studio 
performance are exported with your 
model. 

 
 
 
 

 



6. In the export window, name your model 
file. 

 
7. Make sure the “Export Type” field has 

“COLLADA File” selected. 
 

8. Select a location on your computer to 
export your model file to. 

 
9. Click “Export” in the lower right of the 

export window. 

 

 
 

Note: Make sure your model file and materials 
folder export to the same location on your 
computer. If not, your model will lose it’s 
colors/textures/materials when viewed in 
Studio. 

10. Open zSpace Studio. 
 

11. Click on “Import Model” on the top 
control bar to browse your computer for 
your COLLADA file. 

 
12. Select the COLLADA file and wait for it to 

load in Studio. 

 

 

 

Viewing Your SketchUp Model in zSpace Studio 
Here are things to expect when viewing a COLLADA file from SketchUp. 

● Oftentimes, a DAE file exported from SketchUp will NOT appear correctly in Studio. 

Sometimes materials will not be attached. Sometimes pieces will scatter across the scene in 

Studio. 

 



● You may have to load a SketchUp model file in another program, re-attach materials, and 

make sure piece segmentation is correct, then re-export with the other program to ensure 

that the model can be successfully imported into Studio. 

 

● You may have much better luck with viewing a model from SketchUp when it has been 

exported as an STL file (see picture below), most likely because there are no separate pieces 

or materials. 

● STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL 

file will look like before it is 3D printed. 

● STL files do not show materials or textures. They will appear as a single solid color (usually 

white or grey). 

● STL files show external geometry. This means you see which parts of the model are raised or 

sunken into the model. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Solidworks 

What files can Solidworks open or import? 

Will Import Will Open 

(No import option.) ASM / SLDASM 
DRW / SLDDRW 

DXF 
DWG 
PSD 
AI 

LFP / SLDLFP 
PRTDOT / ASMDOT / DRWDOT 

X_T / X_B / XMT_TXT 
IGS / IGES 
STEP / STP 

IFC 
SAT 
VDA 
WRL 
STL 
CGR 

SLDXML 
PRT / XPR 
ASM / XAS 

PRT 
IPT 
IAM 

PAR / PSM 
ASM 

PRT / CKD 
DLL 

EMN / BRD / BDF / IDB 
3DM 

 

What files can Solidworks save as or export? 

FBX 

This is a file format supported by Studio.  

● You can get this file format option by selecting “Export to FBX”. 

● This file format will not open in Studio. This is most likely because the exporting is being done 

in a way that is incompatible with Unity or zSpace Studio. 

● If you want a 3D model from Solidworks with materials/textures to be viewed in zSpace 

Studio, you’ll need another program like Autodesk Maya to edit and re-export your model file 

in a supported format. 



 

STL 

This is a file format supported by Studio. This format is commonly used for 3D printing. 

● You can get this file format option by selecting “Save as...”. Your model must be saved as an 

ACSII file, not a binary one. 

● This file format will open in Studio.  

 

Other “Save As” Formats 
There are plenty of other formats for “Save as” options, but STL is the only format option for saving 
that is supported by Studio. 
 

Guide to Exporting Your Solidworks Model 
This section will guide you through exporting a 3D model file in Solidworks 2014 that results in a 

format that will load in zSpace Studio. This guide will focus on converting a model into a STL file, since 

that is the only available file format option from this program that will load in zSpace Studio. 

1. Open or load your model in the scene. 
You can drag your model file into the 
scene to load it. 

 
2. Make any last-minute changes to your 

model, if necessary. You won’t be able 
to edit your model in Studio. 

 
3. Hover over the grey arrow pointing to 

the Solidworks logo to bring up the 
“File” menu (see green arrow in 
screenshot to the right). 

 
4. In the “File” menu, select “Save As…” 

 

 

5. In the “Save As” window, name your 
model file. 

 
6. Make sure the “Save As Type” field has 

“STL” selected. 
 

7. Select a location on your computer to 
export your model file to. 

 
8. Click on “Options” in the lower left of 

the “Save As” window. 

 

 



Make sure these options are selected: 
 

9. Under “Output as” make sure ACSII is 
selected, not Binary. 

 
10. In the group of 3 checkboxes in the 

middle of the window, check the box 
that says “Save all components of an 
assembly in a single file”. 

 
11. Click “Save” in the lower right of the 

export window. 

 
Note: This window will say “Export Options”, 
but it is your option window when saving. 

12. Open zSpace Studio. 
 

13. Click on “Import Model” on the top 
control bar to browse your computer for 
your STL file. 

 
14. Select the STL file and wait for it to load 

in Studio. 

 

 

 

Viewing Your Solidworks Model in zSpace Studio 
Here are things to expect when viewing a STL file from Solidworks. 

● STL files are often used for 3D printing, so you can use zSpace Studio to view what your STL 

file will look like before it is 3D printed. 

● STL files do not show materials or textures. They will appear as a single solid color (usually 

white or grey). 

● STL files show external geometry. This means you see which parts of the model are raised or 

sunken into the model. 

● You can use the cutting plane tool in Studio to view whether your model is hollow or solid. 

 


